+378 (0549) 941539      registration@smar.aero

TCAS II Version 7.1 Requirements Coming to European Union


September 7, 2015

Eurocontrol has announced that all aircraft equipped with TCAS II version 7.0 must upgrade to version 7.1 by December 1, 2015 to conduct flights in European airspace. Aircraft manufactured after March 1, 2012, must now be equipped with version 7.1 A regulatory decision regarding implementation was published in the Official Journal of the European Union December 20, 2011.

The development of version 7.1 was initiated by Eurocontrol following the discovery of two safety issues with the current TCAS II version.